Mail Delivery Issues
Incident Report for Wiredrive
Resolved
Our upstream provider has confirmed that this issue is resolved.
Posted Feb 19, 2020 - 20:38 PST
Monitoring
System emails are now being sent through a secondary system, and we can confirm that they are being delivered successfully. We are continuing to monitor the situation with our primary provider.
Posted Feb 19, 2020 - 16:46 PST
Identified
We can confirm that system emails are not being delivered due to an issue with an upstream provider. We are working with them to resolve. We would recommend sharing any presentation by selecting "Get Link" as a temporary workaround.
Posted Feb 19, 2020 - 16:37 PST
Investigating
We are investigating reports of system emails not being delivered.
Posted Feb 19, 2020 - 16:26 PST
This incident affected: Email Delivery.