Wiredrive Uploads
Incident Report for Wiredrive
Resolved
Our team has addressed upload issues for Wiredrive so uploads should be working as expected. Please reach out to our support team at support@wiredrive.com if anyone is experiencing additional upload issues.
Posted 3 months ago. Jun 22, 2018 - 14:48 EDT
Investigating
Our team is starting to receive reports of the inability to upload to Wiredrive and we are currently investigating. Will provide updates as they come.
Posted 3 months ago. Jun 22, 2018 - 14:27 EDT
This incident affected: Wiredrive (Site Availability).